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Enero 2023

Descarga Unity

Descargamos Unity hub
https://unity3d.com/get-unity/download

Método de instalacién con apt metiendo el server en sources:

echo "deb https://hub.unity3d.com/linux/repos/deb stable main" >
/etc/apt/sources.list.d/unityhub.list’

Descargamos la key. La mete en trusted.gpg pero eso es deprecated y la movemos a trusted.gpg.d
mv /etc/apt/trusted.gpg /etc/apt/trusted.gpg old

wget -q0 - https://hub.unity3d.com/linux/keys/public | sudo apt-key add -
mv /etc/apt/trusted.gpg /etc/apt/trusted.gpg.d/hub.unity3d.com.gpg

Luego lo instalamos

apt update
apt-get install unityhub

Instalamos hub/editor (son unas 5Gb)
Instalamos la Ultima versién LTS que es 2021.3.16f1 y la ultima que hay que es 2022.2.2f1

https://developer.oculus.com/downloads/package/unity-integration-archive/

Nuevo Proyecto

https://www.youtube.com/watch?v=apL9lIkKLHQ

Nuevo Proyecto como 3D
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New project
Editor Version: 2021.3.16f1 [ixs

All templates

New

?

Sample
Learning

3D
This is mpty 3D project that uses Unity's
2D (URP) built-in
Core

Read more

Project name

oculus_01

Runner Game

Core
Location
/homefjose/personalfunity

3D Mobile

Core

2N Maohile

Cancel Create project

Vamos a “File > Build Settings” y seleccionamos android y pulsamos switch platform

File Edit Assets GameObject Component Window
New Scene
Open Scene @ Gam guild Settings

Open Recent Scene 1 scenes InBuild

ne Template...

Add Open Scenes
Build Settings... Shift+Ctri+B Platform W Android
Build And Run

— g Windows, Mac, Linux Texture Compression Use Player Settings
Exit LI ETC2 fallback 32-bit

B H £, Sar -
E Dedicated Server Export Project

F--%
|'| Android

Build App Bundle {Google Play)
WTHL ~ o o ~vmhbn in i
E WebGL Create symbols.zip Disabled

M Project B console
+~ i
Development Build
W Favorites + Assets
O, All Materials
G, All Models

Q, All Prefabs .

[ Assets
I Scenes E: o Asset Import Overrides
@@ Packages

i Code CU";W"‘_”B Texture Compression  No Override
Im Custom NUnit

Compression Method

Max Texture Size No Override

Learn about Unity Cloud Build

I Editor Coroutines Player Settings... Switch Platform Build And Rur
I JetBrains Rider Editor
I Newtonsoft Json

M Profile Analyzer

En “Texture Compression” seleccionamos la recomendada para Oculus: ASTC
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Build Settings

Scenes In Build

Add Open Scenes
Platform W Android
g Windows, Mac, Linux exture Compressio Use Player Settings

. ) - (v Use Player Settings
E Dedicated Server ¥port Proiect
ETC (GLES 2.0)

|ﬁ| Android
ndroic

Build App Bundle {

HTHL

E WebGL Create symbols.zip

DXT (Tegra)
PVRTC (PowerVR)

Development Build

Compression Method
Asset Import Overrides
Max Textura Size Mo Override

Texture Compression  No Override

Learn about Unity Cloud Build

Player Settings... Build * Build And Run

Ahora instalamos el plugin de XR. “Edit > Project Settings” luego “XR Plugin Management” y “Install
XR Plugin Management”. También lo podemos instalar desde “Window > PAckage Manager”
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Unity - oculus_01 - SampleScene - Android - Unity 2021.3.16f1 Personal <OpenGL 4.5>

Window Help

X Project Settings

Audio

Editor QI 58 the new XR Plugin ¢ e XR Plugin Management package. Clicking the button below will install the latest XR Plugin
! XR.
Graphics - -

Input Manager Install XR Plugin Management
Memory Settings

Package Manager

Physics

Physics 2D

Player

Preset Manager

Quality

Scene Template

Script Execution Order

Adaptive Performance XR Plugin Management

Services
Ads
Cloud Build
Cloud Diagnostics
Collaborate
In-App Purchasing
Tags and Layers
TextMesh Pro
Time
Timeline
Toolchain Management
Ul Builder
Version Control

1al Serintine

XR Plugin Management

En la pestafia de Android, seleccionamos Oculus

X Project Settings

Adaptive Performance XR P|ug-in Management
Audio
Editor
Graphics [
Input Manager
Memory Settings Initialize XR on Startup
ank_a-Lie Manager Plug-in Providers @
5
sics 2D ARCore
v Oculus
Preset Manager
Quality Unity Mock HMD
Scene Template
Execution Order

Services

Ads

Cloud Build

Cloud Diagnostics

Collaborate

In-App Purchasing
Tags and Layers
TextMesh Pro
Time
Timeline
Toolchain Management
Ul Builder
Version Control
Visual Scripting
XR Plug-in Management

Oculus

Instalamos “XR Interaction Toolkit unity”. Seleccionamos “Window > Package Manager”
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File Edit Assets GameObject Component Window Help

L & @ Panels Y
= Hierarchy = MWext Window Ctri+Tah
S = F Previous Window Shift+Ctri+Tab
' SampleScene :

) Main Camera
(1 Directional Light

Layouts 4
Search
Collaborate
Plastic SCM
Asset Store
Package Manager
Asset Management
Text

TextMeshPro
General

Rendering
Animation

Audio

Sequencing
Analysis

Al

UI Toolkit

v v v v v v v W ¥ v v w

Visual Scripting

Seleccionamos “Unity Registry” e instalamos “XR Interaction Toolkit”
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Package Manager - B X

B Package Manager

=+ ~ Pac
st [+ Unity Registry
In Project
My Assets

Built-in

C ers and |
fles, including

Unity LI
Universal RP

sion Control

Visu

Visual 5

Install

Nos dice que reiniciar, le damos que si.

i i
= Warning x
This project is using the new input system package but the native platform
backends for the new input system are not enabled in the player settings.
This means that no input from native devices will come through.

Do you want to enable the backends? Doing so will *RESTART* the editor.

es Mo

Importamos los ejemplos:
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= Package Manager - O x

XR Interaction Toolkit

Unity Technologies
Version 2.0.4 - November 03, 2022

Timeline

Tutorial Authorin
Tutorial Frame
Unity

Unity P

Unity T

Unity U

Impart

Import

Remove

Anadimos las acciones a las manos. Vamos a “Assets > Samples > XR Interaction Toolkit > 2.04 >
Starter Assets”. Para verlo en modo lista, seleccionamos la barra de preview de la derecha al minimo.
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Seleccionamos los siguientes Assets:

XRI Default Left Controller
XRI Default Left Grab Move

XRI Default Right Controller
XRI Default Right Grab Move

y pulsamos a la derecha:
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“Add to ActionBaseController default”

XRI Default Left
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Add to ActionBasedController default
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Input
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Ahora vamos a “Edit > Project Settings” y en “Preset Manager” y ponemos “Left” y Right”

Project Settings

Preset Manager

{UnityEng

{UnityEn

Add Default Preset

Anadimos a la escena el jugador, que seria “XR > XR Origin (Action-Based)” En la Ultima versién es
“XR Origin (VR)” Importante haber hecho antes lo de asignar los Assets en los controles, sind, nos
afadird el XR Origin pero sin acciones en las manos.
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Ray Interactor (Action-based)
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s
-
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Visual Scripting Scene Variables Direct Interactor (Action-based)
Move To View Socket Interactor
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Align View to Selected Interaction Manager

Toggle Active State ¥R Origin (Action-based)

All Prefabs Locomotion System (Action-based)
Teleportation Area
Teleportation Anchor
UI Canvas

UI EventSystem

XR Origin

Anadimos un plano para tener referencia
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Descarga Unity

a .

= Hierarchy = o Game

+ - ._ ::: _H-{r -

Create Empty

Create Empty Child

Effects 4 Sphere

Light 4 Capsule

Audio 4 Cylinder

Video 4

UI 4 Quad

UI Toolkit 4 Text - TextMeshPro
XR » Legacy 4
Camera Ragdoll...

Visual Scripting Scene Variables Terrain

Tree

Wind Zone

Si queremos bajamos el suelo un poco para que quede por debajo del jugador

Nos fijamos que XR Origin tenga el componente “Input Action Manager” y que en “Action Assets”

tenga “XRI Default Input Actions”

Coger un objeto a distancia

https://www.youtube.com/watch?v=rhD4 NJMI-g

Descargamos linterna de asset store pulsando “add to my assets”

https://assetstore.unity.com/packages/3d/props/electronics/flashlight-18972

En unity lo importamos, Vamos a “Window > Package Manager” y seleccionamos “My Assets”
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e ¥ Filters» C
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Package Size Supported Unity Versions

Size: 71.08 ME (Number of fi
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Download

Si no nos aparece, le damos abajo a refrescar. Seleccionamos la linterna y damos a download
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Luego nos aparecera import, pulsamos y se abrira otra ventana y nuevamente import.
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Nos aparece en nuestros Assets. La arrastramos a nuestra escena, en la pantalla o a la lista de
izquierda.
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BJ ~ Mesh Renderer
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™ v Animator
Flashlight

W9 Flashlight
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Create Empty

Create Empty Child
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3D Object 4

Effects 4 Sphere

Light > Capsule

Audio » Cylinder
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Move To View Tree
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Align View to Selected
g Flashlight » Flashlight_Gold

Toggle Active State

':'_ All Prefab: -

Deshabilitamos la luz de ambiente. Seleccionamos “Directional Light” y quitamos el check.
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@& Game

ght > Flashlight_Gold

Add Component

ag Untagged *  Layer [Default

Transform

Anadimos el componente a la linterna para que la podamos coger. Abajo en el menu de la derecha y
estd “Add Component” y selecctioamos “XR Grab Interactable”
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La coge con el botdén (dedo anular) pero en perpendicular:
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Tenemos que crear un un nuevo elemento a la linterna. Pulsamos botén derecho y pulsamos “Create
Empty”
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= Hierarchy

i@ Flashlight

G W
Rename

Duplicate

Delete

Select Children

Set as Default Parent
Prefab

Create Empty
Create Empty Parent
3D Object

Effects

Liaht

Por defecto pone “GameObject”, le cambiamos el nombre a “PuntoCogida”

File Edit Assets GameObject Component Window Help
8L & B
= Hierarchy

SampleScene®

lain Camera

controller

Serd el punto en el que lo cojamos. Ponemos Rotation: -90, 0, 180
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s Game
& SampleScene*

¥ Flashlight
£ W

Flashlight_Gold

= v - B -
i o Er G v PuntoCogida

ag Untag

Transform

Add Component

Ahora para aplicar la transformacion, tenemos que arrastrar el gameobject “PuntoCogida” a la
linterna, en “XR Grab Interactable > Attach Transform” o seleccionarlo.
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o Game

H o

ashlight > Flashlight_Gold

Quedaria asi:

Mesh Renderer
« Animator
Rigidbody

¥ Box Collider
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Ahora ya la coge bien.
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Si pulsamos el stick del mando el objeto se aleja. Si queremos quitar este efecto es con “Anchor
Control”

Ahora falta hacer que al pulsar el botén se encienda la luz. Usamos los action events. Vamos a “XR
Grab Interactable > Interactable Events”
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= )
W% ~ Box Collider
ﬁ ¥ XR Grab Interactable

B xR Interaction Manager
Default
Colliders
Mone (Game Ot
Single
Instantaneous
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(Transform)

ch Ease In Time

Attach Point Compatibility Mc Default (Recommended)

teractable Events
First/Last Hover

First Hover Entered (HoverEnterEvents

List is Empty
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El botdn de activar es el gatillo. El botdn “Select” es el anular y “Activate” el gatillo. Pulsamos el + en
Activate para afadir propiedad. Arrastramos la luz encendida (WhiteLight) ponemos
“GameObject.SetActive” y marcamos el check.
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Flashlight_Gold

Para que se apague, hacemos lo mismo en Deactivated pero sin marcar el check:

Activate
ivateEvents
Runtime Only = GameObject.SetActive

i WhiteLight

Deactivated (Deact

Runtirme Only GameObject.SetActive

i WhiteLight

Anadir manos

Descargamos el asset “Oculus Hands Physics.unitypackage”

https://download2270.mediafire.com/ikdov34vpujg/r8vmytboostszzj/Oculus+Hands+Physics.unitypac
kage

Lo adjunto por si acaso:
oculus_hands_physics.unitypackage.gz

Para instalar el Asset, arrastramos dentro de Assets el fichero “oculus_hands_physics.unitypackage” o
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lo afhadimos desde “Assets” > “import package” > “Custom Package”

Ahora lo anadimos a las manos arrastrando el asset “Oculus Hands Physics > Prefabs > Left Hand
Presence” a la mano izquierda y el derecho a la derecha

o Game

-

i@ Lintern:

5 Loacomotion

B Console

W Favorites

2, All Materials

Q, All Pre

I Animations
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Coger un objeto a mano

Vamos a hacer que la mano izquierda coja los elementos en local sin necesidad del rayo. Vamos a left
hand controller y eliminamos “XR Ray Interactor”

..... Layer Default

# XR Controller (Action-based)
¥R Ray Interactor
’ Line Renderer

* ¥R Interactor Line Visual Remove Component
Rigidbody

Move Up

default-Line (Material)
Move Down

Copy Component

Add Component

Find References In Scene

Properties...

Edit Script

Y ahora anadimos “XR Direct Interactor”
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Add Component

Search
Debug Ul Handler Indirect Float Field

] Ul Handler Indirect Tot

a Milraster

xR Direct Interactor

Para que pueda coger el objeto, tenemos que afadir en la mano también el componente “Sphere
Collider”
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Y luego marcarlo como Trigger
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# ¥R Controller {Action-based)

th

XR Ray Interactor

th

/ Line Renderer

th

# XR Interactor Line Visual
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Override Line Length
Line Lengt
p Line
ooth Movement
Mone (Game Ohbj
Rigidbody
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Center

Add Component

Si no coge el objeto, cuidado que a veces se cambian las coordenadas del Box Colider que le hemos
puesto en la mano. Poner a 0

Movimiento Continuo

https://www.youtube.com/watch?v=706Bx0hutM0

Creamos GameObject y lo Ilamamos “LocomotionSystem” y le asignamos con “Add Component” >
“Locomotion System”

Arrastramos nuestro “XR Origin” a la casilla “XR Origin” del componente “Locomotion System”
Al jugador (XR Origin) le anadimos con “Add Component”:

1. Continuous Move provider
2. Continuous Turn provider

Seleccionamos la mano derecha para girar. Pulsamos en “Continuous Turn Provider”, marcamos el
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check de “Use Reference” y en “Reference” ponemos “XRI RightHand Locomotion Turn”

" Tag Untagged ~  Layer Default

T+

Transform
XR Origin

Input Action Manager

L )

#

Continuous Move Provider (Action-based)

T+

Continuous Turn Provider (Action-based)
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Reference 7. XRI RightHand Locomotien/Turn (Inp
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Tag Untagged v Layer Default

2 Transform

B v Xrorigin
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Scene
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i =
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Action
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Reference XRI LeftHand Locomotion/Move (Inp
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Add Component
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and Interaction/Trar

ftHand Locomotion/Grab Move
ftHand Locomotion/Move
ftHand Locomotion/Snap Turn

and Locomo
and Locomotiol

fault Input Actions.inputactions

Ahora tenemos que anadir que haga colisidon con los objetos. Afladimos a “XR Origin” el componente
“Character Controller” y “Character Controller Driver”. En “Character Controller Driver” ponemos “Min
Height” 1y “Max Height” 2 que seria altura entre 1 metro y 2 metros.
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:‘"‘ + Character Controller

Slope Limit

Skin Width

Min Move Distance

# Character Controller Driver
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Min Height 1
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Add Component

Hay un problema que hace colisién con un objeto cogido y empiezas a volar
https://forum.unity.com/threads/grab-able-objects-interfering-with-locomotion-system.1258443/
Una posible solucion:
https://forum.unity.com/threads/grabbed-rigidbody-is-moving-my-xr-rig.1087481/

Lo he solucionado de momento poniendo los objetos en diferentes layers que el cuerpo. Para crear
una layer en las propiedades del objeto dentro de layers:

O Inspector

."'"' + Linterna
b
Tag
Prefab Open Selec 0: Default

s Transform 1: TransparentFx

Position 2: Ignore Raycast
(v 3: Objetos

4: Water

Rotation

Scale

Bl  LP_Flash Light (Mesh Filter)
@ + Mesh Renderer

50Ul

&6: Jugador
Materials Jug

Lighting Add Layer...

Probes
Additional Settings

Ponemos el XR Origin (pero sin los children) en un layer, por ejemplo que se llame “jugador” y los
objetos en otra layer que se llame objetos. Al cambiar “XR Origin” a la layer Jugador, le tenemos que
decir que no cambie los children, porque sind, también cambiaria las manos y no podriamos coger los
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onjetos.

Change Layer

Do you want to set layer to Jugador for all child objects as well?

Mo, this object only Yes, change children Cancel

Ahora en la matriz de colisiones decimos que esas dos layers no colisionen. Vamos a “Edit > Project
Settings” y en “Physics” quitamos el check en el que coinciden las dos layers

= Project Settings - o x

tings

Performance Ph ySiCS

Patch Friction Type

Projected Gau

sable All  Enable All

Teleport

Teletransportacion

https://www.youtube.com/watch?v=ukZWzDqtcCQ
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